Upgrade Requirements for MongoDB Versions

Upgrade Requirements for MongoDB 3.4

If you’re running a version of MongoDB before MongoDB 3.2, you must first upgrade to MongoDB 3.2 before upgrading to MongoDB 3.4.

Once an mLab-hosted deployment is running MongoDB 3.4, it cannot be downgraded to an earlier release version without significant downtime. We strongly advise that you refrain from using any features new to 3.4 until you are confident that your deployment is healthy running on version 3.4.x.

With MongoDB version 3.4, you should be aware of the fact that:

Before upgrading, you must do the following:

Upgrade Requirements for MongoDB 3.2

If you’re running a version of MongoDB before MongoDB 3.0, you must first upgrade to MongoDB 3.0 before upgrading to MongoDB 3.2.

With MongoDB version 3.2, you should be aware of the fact that:

Before upgrading, you must do the following:

Upgrade Requirements for MongoDB 3.0

If you’re running a version of MongoDB before MongoDB 2.6, you must first upgrade to MongoDB 2.6 before upgrading to MongoDB 3.0.

Once an mLab-hosted deployment is running MongoDB 3.0, it cannot be downgraded to an earlier release version. Before upgrading, we strongly recommend testing the connectivity of your entire stack on a MongoDB 3.0 deployment with a SCRAM-SHA-1 authSchema, such as an mLab-hosted 3.0 Shared Cluster deployment.

With MongoDB version 3.0, you should be aware of the fact that:

Before upgrading, you must do the following:

  1. Review the full list of 3.0 changes that can affect compatibility with older version of MongoDB.
  2. Upgrade all connecting apps to use a MongoDB 3.0 and SCRAM-SHA-1-compatible driver (Moped/Mongoid users, see note below).

Moped (used by Mongoid 4 and below), is not compatible with MongoDB version 3.0 because it does not support SCRAM-SHA-1 authentication. If you’re using Mongoid, you must upgrade to Mongoid 5 before upgrading your mLab-hosted deployment to 3.0.




Click here to view upgrade requirements for versions no longer supported by mLab.